Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-3409

DSC - Deprecate PowerShell and Stdlib Puppet Module Dependecy

    XMLWordPrintable

Details

    • Improvement
    • Status: Resolved
    • Normal
    • Resolution: Done
    • None
    • None
    • dsc, powershell
    • None
    • Hide

      Removing the powershell puppet module should not remove or break any functionality in the current dsc module. All spec tests and acceptance test should continue to work, with the exception of the acceptance test targeted at lcm_config, which should be removed.

      Show
      Removing the powershell puppet module should not remove or break any functionality in the current dsc module. All spec tests and acceptance test should continue to work, with the exception of the acceptance test targeted at lcm_config, which should be removed.
    • Modules
    • 1

    Description

      https://github.com/puppetlabs/puppetlabs-dsc/issues/203 asks us to update the powershell ref to use latest. This be converted into a ticket to remove the puppet powershell module as dependency. The only reason to have it is to use lcm_config, which changes the LCM RefreshMode to allow Invoke-DscResource. In the RTM release of WMF5, this isn't needed anymore as the RefreshMode is already set to allow it. To remove the powershell module, it would require removing the lcm_config manifest entirely.

      Attachments

        Issue Links

          Activity

            People

              james.pogran James Pogran
              james.pogran James Pogran
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support