Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-3710

[puppet_agent] module incompatible with strict_variables

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: puppet_agent 1.2.0
    • Fix Version/s: puppet_agent 1.3.2
    • Component/s: puppet_agent
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Testing should verify that the module can be applied with strict_variables enabled.

      Show
      Testing should verify that the module can be applied with strict_variables enabled.
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Module should now compile with strict_variables enabled.

      Description

      Filed as https://github.com/puppetlabs/puppetlabs-puppet_agent/issues/141

      module fails to compile if strict_variables is set to true

      Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Evaluation Error: Error while evaluating a Resource Statement, Evaluation Error: Unknown variable: '_package_version'. at /etc/puppetlabs/code/environments/production/modules/puppet_agent/manifests/init.pp:108:8

      Code broken at https://github.com/puppetlabs/puppetlabs-puppet_agent/blob/1.2.0/manifests/init.pp#L108

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            michael.smith Michael Smith
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support