Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-3776

puppetlabs_spec_helper 1.2.0 now requires ruby >= 2.2

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Normal
    • Resolution: Fixed
    • None
    • None
    • None
    • None
    • 1
    • MODS 2016-08-24

    Description

      With the release of puppetlabs_spec_helper 1.2.0, it's pulling in a gem that has the requirements of >= ruby 2.2. This breaks existing CIs that are leveraging upstream versions of ruby as currently 2.2 is not readily available.

      https://github.com/puppetlabs/puppetlabs_spec_helper/blob/master/puppetlabs_spec_helper.gemspec#L58

      Pulls in rubocop-rspec ~>1.6 which is ruby >= 2.2. https://rubygems.org/gems/rubocop-rspec

      Additionally puppetlabs_spec_helper does not properly add this requirement to the gem in addition to breaking any existing usages on ruby 2.1

      Attachments

        Activity

          People

            david.schmitt David Schmitt
            mwhahaha Alex Schultz
            Votes:
            2 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support