Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-4066

Powershell not executing on Windows Server 2016 Standard (or silently failing)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: powershell
    • Labels:
      None
    • Template:
    • Team:
      Modules

      Description

      I've built out a rather thorough manifest for setting up IIS all the way through installing SSL certs and even applying IISCrypto.

      I've been able to successfully test and run these against Windows Server 2012 R2 Standard machine but when run against Windows Server 2016 Standard, I do something as simple as:

      exec

      { '[debug]': command => 'Remove-Item C:\test.txt', provider => 'powershell' }

      Running Puppet agent (ondemand) yields the following output:

      Notice: /Stage[main]/V6/Exec[[debug]]/returns: executed successfully

      But the file is still there (no effect).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              mattborja Matt Borja
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support