Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-4508

puppetlabs-chocolatey error message "Cannot bundle unregistered option '-e' "

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: chocolatey
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Puppetlabs/Chocolatey should be able install or upgrade a package without getting a bundle error

      Show
      Puppetlabs/Chocolatey should be able install or upgrade a package without getting a bundle error
    • Team:
      Modules
    • CS Priority:
      Major
    • QA Risk Assessment:
      Needs Assessment

      Description

      The puppet labs chocolatey module is trying to install an application, but fails to properly parse the command. According to this ticket the command should use --version instead of -version.

      Error message

      change from absent to 6.9.2 failed: Could not update: Execution of 'C:\ProgramData\chocolatey\bin\choco.exe upgrade notepadplusplus -version 6.9.2 -y --ignore-package-exit-codes' returned 1: Parsing -version resulted in error (converted to warning): Cannot bundle unregistered option '-e'. Chocolatey v0.10.3

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              james.pogran James Pogran
              Reporter:
              Derek.Robinson Derek Robinson
              Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support