Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-4547

[puppet_agent] expects package provider to be system default

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet_agent 1.4.1
    • Component/s: puppet_agent
    • Labels:
      None
    • Template:
    • Team:
      Agent
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Now explicitly uses the system package provider on Solaris 10.
    • QA Risk Assessment:
      Needs Assessment

      Description

      The puppet_agent module has a set of packages provided by Puppet that it expects to work with, but does not explicitly select package providers. In environments where the default package provider has been changed, this causes the module to fail. We should hard-code package providers.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            michael.smith Michael Smith
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support