Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-4987

puppet_agent: Make apt/transition soft dependencies

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppet_agent, supported
    • Labels:
    • Template:
    • Team:
      Platform OS
    • QA Risk Assessment:
      Needs Assessment

      Description

      From https://github.com/puppetlabs/puppetlabs-puppet_agent/issues/230:

      ```
      Warning: Module 'puppetlabs-apt' (v4.0.0) fails to meet some dependencies:
      'puppetlabs-puppet_agent' (v1.3.2) requires 'puppetlabs-apt' (>= 2.0.1 < 3.0.0)
      ```
      According to the Puppet Style Guide https://docs.puppet.com/puppet/latest/style_guide.html#dependencies , epel and apt are soft dependencies and should be treated as such.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              geoff.nichols Geoff Nichols
              Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:

                  Zendesk Support