Affects Version/s: None
Fix Version/s: None
OS: Centos 7.3.1611
Puppet Enterprise version (2017.1): 4.9.4
puppetlabs-java version: 1.6.0 (also tested with 2.0.0)
I get an Error: Invalid relationship: error when using the require attribute of a resource to validate Java is already installed.
For example, this class:
WIll yield this error when run on a client:
I came across this bug? while preparing to upgrade PE from 3.8.4 to 2017.1 (4.9.4). I also applied that same example code to a PE 3.8.4 installation and I do not get any errors. I used the same java module (1.6.0) in both cases.
I also tested this on PE (4.9.4) with the Java 2.0.0 module as well. I still get the error.
I can work around the issue by changing the require to match only 'java' (instead of 'jdk1.8.0_141)