Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-5566

puppetlabs/sqlserver : runs fail if RS is installed but database engine services are not

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: sqlserver
    • Labels:
      None
    • Template:
      MODULES Bug Template
    • Acceptance Criteria:
      • Instance facts should support Reporting Services being the only installed option in an instance.
    • Team:
      Windows
    • Sprint:
      Windows Kanban
    • Method Found:
      Customer Feedback
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 2.0.0
      Puppet Version: 2016.4.2
      OS Name/Version: Windows Server 2016

      Describe your issue in as much detail as possible...

      Desired Behavior:
      Installing the reporting services feature is successful and does not prevent future agent runs, regardless of whether the database engine services are installed or not.

      Actual Behavior:
      Reporting Services are installed correctly during the first run, however every subsequent run attempts to reinstall RS, causing a failure.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              michael.lombardi Michael Lombardi
              Reporter:
              paul.schaffer Paul Schaffer
              Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support