Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-5693

puppetlabs-sqlserver Module uses SQLOLEDB to connect to server, cannot use TLSv1.1 or TLSv1.2

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: SQL Server 1.1.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Windows
    • QA Risk Assessment:
      Needs Assessment

      Description

      Because the SQL Server Module uses SQLOLEDB to connect to the server and SQLOLEDB does not permit the use of TLSv1.1 or TLSv1.2, any deployment which mandates the use of TLSv1.1 and/or TLSv1.2 cannot use the module.

      Is there a different connector which can handle newer TLS transport encryption which can be used by the module, or are there plans for SQLOLEDB to support TLS above TLSv1.0?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              michael.lombardi Michael Lombardi
              Reporter:
              stefan.pijnappels Stefan Pijnappels
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support