Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-6280

puppet_agent : ensure compatibility to puppetlabs/apt > 3.0.0

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: puppet_agent 0.2.0, puppet_agent 1.0.0, puppet_agent 1.1.0, puppet_agent 1.2.0, puppet_agent 1.3.0, puppet_agent 1.3.1, puppet_agent 1.3.2, puppet_agent 1.4.0, puppet_agent 1.4.1, puppet_agent 1.5.0
    • Fix Version/s: puppet_agent 2.0.0
    • Component/s: puppet_agent
    • Labels:
      None
    • Template:
    • Team:
      Platform OS
    • Sprint:
      Platform OS Kanban
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 1.5.0
      Puppet Version: *
      OS Name/Version: Debian OS Family

      The module depends on the puppetlabs/apt module. The version of it has to be < 3.0.0. Some newly created modules (e.g. puppetlabs/kubernetes) require newer versions of puppetlabs/apt, which makes them incompatible to puppetlabs/puppet_agent.

      Desired Behavior:
      puppetlabs/puppet_agent is compatible with some more current version of puppetlabs/apt.

      Actual Behavior:
      puppetlabs/puppet_agent is compatible only with puppetlabs/apt < 3.0.0.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              juckerf Fabian Jucker
              Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support