Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-6450

dsc_lite: Add Beaker test for installing DSC resources via module

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Normal
    • Resolution: Won't Do
    • None
    • None
    • dsc_lite
    • None
    • Hide

      A new test / test case that uses Install-Module with .zip files for the multiple versions of PuppetFakeResource

      Show
      A new test / test case that uses Install-Module with .zip files for the multiple versions of PuppetFakeResource
    • Windows
    • Needs Assessment

    Description

      There is currently a test that installs DSC resources using xcopy deployment style to multiple parts of the $ENV:PSModulePath.

      It would also be good to use the Install-Module cmdlet as discussed at https://github.com/puppetlabs/puppetlabs-dsc_lite/pull/17#discussion_r160321672 to install using the versioned directory structure hierarchy.

      This probably involves creating on-the-fly modules from PuppetFakeResource / PuppetFakeResource2 and then using those as fixtures.

      Note that MODULES-5845 has added version support, but because this test does not yet exist, has not introduced a new test yet using paths to modules and versions. This ticket should introduce that test.

      Attachments

        Issue Links

          Activity

            People

              william.hurt William Hurt
              ethan Ethan Brown
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support