Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-6592

puppetlabs-dsc : Update module to latest DSC Resource versions

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: dsc
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide
      • The latest versions of all DSC Resources included in the PowerShell/DSCResources repo should be present
        • xTimeZone 1.7.0.0
        • xSharePoint 2.1.0.0
        • xRemoteDesktopSessionHost 1.5.0.0
        • xPSDesiredStateConfiguration 8.0.0.0
        • xNetworking 5.5.0.0
        • xHyper-V 3.11.0
        • xFailOverCluster 1.9.0.0
        • xExchange 1.19.0.0
        • xDnsServer 1.9.0.0
        • xDatabase 1.7.0.0
        • xComputerManagement 4.0.0.0
        • xCertificate 4.2.0.0
        • xAdcsDeployment 1.4.0.00
        • xActiveDirectory 2.17.0.0
        • SystemLocaleDsc 1.2.0.0
        • SharePointDsc 2.1.0.0
        • SecurityPolicyDsc 2.2.0.0
        • OfficeOnlineServerDsc 1.2.0.0
        • SqlServerDsc 11.0.0.0
        • StorageDsc 4.0.0.0
      • DSC_Resources_Tags should be current version
      • There are no import errors from running rake dsc:build
      Show
      The latest versions of all DSC Resources included in the PowerShell/DSCResources repo should be present xTimeZone 1.7.0.0 xSharePoint 2.1.0.0 xRemoteDesktopSessionHost 1.5.0.0 xPSDesiredStateConfiguration 8.0.0.0 xNetworking 5.5.0.0 xHyper-V 3.11.0 xFailOverCluster 1.9.0.0 xExchange 1.19.0.0 xDnsServer 1.9.0.0 xDatabase 1.7.0.0 xComputerManagement 4.0.0.0 xCertificate 4.2.0.0 xAdcsDeployment 1.4.0.00 xActiveDirectory 2.17.0.0 SystemLocaleDsc 1.2.0.0 SharePointDsc 2.1.0.0 SecurityPolicyDsc 2.2.0.0 OfficeOnlineServerDsc 1.2.0.0 SqlServerDsc 11.0.0.0 StorageDsc 4.0.0.0 DSC_Resources_Tags should be current version There are no import errors from running rake dsc:build
    • Epic Link:
    • Team:
      Windows
    • Sprint:
      Windows Kanban
    • QA Risk Assessment:
      Needs Assessment

      Description

      Update the dsc module to the latest versions of the DSC Resources in the PowerShell git repo using the built-in rake tasks.

       

      The latest versions include the October, November, December, and February releases

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              james.pogran James Pogran
              Reporter:
              james.pogran James Pogran
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support