Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-6603

puppetlabs-puppet_agent : Update Puppetlabs-Apt dependency to current release

    XMLWordPrintable

Details

    • Improvement
    • Status: Accepted
    • Normal
    • Resolution: Unresolved
    • None
    • None
    • puppet_agent, supported
    • Platform OS
    • Normal
    • 2 - 5-25% of Customers
    • 2 - Annoyance
    • 3 - $$$$
    • Hide
      If a customer is already using a current version of the puppetlabs-apt module it's a pain to work around this requiring either a downgrade of the module and dealing with errors or setting up a separate environment for the nodes which need upgrades. Ideally this module would use a current version so customers don't face this trouble.
      Show
      If a customer is already using a current version of the puppetlabs-apt module it's a pain to work around this requiring either a downgrade of the module and dealing with errors or setting up a separate environment for the nodes which need upgrades. Ideally this module would use a current version so customers don't face this trouble.
    • Needs Assessment

    Description

      The puppet_agent module has the following dependency on the puppetlabs-apt module

      puppetlabs-apt (>= 2.0.1 < 3.0.0)

      Please update the dependency to the current release of the puppetlabs-apt module which is at v4.4.1 (4.x)

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              joshua.keiser Joshua Keiser
              Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:

                Zendesk Support