Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-7011

puppetlabs-powershell : When using PS 2.0 .Net 3.5 is required to be present

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PowerShell 2.1.5
    • Component/s: None
    • Labels:
      None
    • Template:
      MODULES Bug Template
    • Team:
      Windows
    • Story Points:
      1
    • Sprint:
      Windows 2018-04-25
    • Method Found:
      Needs Assessment
    • CS Priority:
      Needs Priority
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 2.1.4
      Puppet Version: 207.3.2 ( 5.3.3)
      OS Name/Version: windows server 2008 r2, powershell 2.0

      When using powershell 2.0 without .net 3.5 installed, instead 4.x only is present, an error message is displayed on each puppet run (full message appended to the bottom of the form) the message indicates that .net 3.5 or greater should be installed.

      The issue appears to originate in the code below, where it assumes 3.5 is present if .net 4 is installed

      _https://github.com/puppetlabs/puppetlabs-powershell/blob/031c37a4e877c35995b778469d547c5c54913b0c/lib/puppet_x/puppetlabs/powershell/compatible_powershell_version.rb#L38_

      Desired Behavior:

       

      A check for any compatible .net Version

      Actual Behavior:

      Assumes .NET >3..4 is not present if 3.5 is not present

       

       

       

      error message:

       

      Currently, the PowerShell module has reduced v1 functionality on this agent due to one or more of the following conditions: - Puppet 3.x (non-x64 version) Puppet 3.x uses a Ruby version that requires a library to support a colored console. Unfortunately this library prevents the PowerShell module from using a shared PowerShell process to dramatically improve the performance of resource application. - PowerShell v2 with .NET Framework 2.0 PowerShell v2 works with both .NET Framework 2.0 and .NET Framework 3.5. To be able to use the enhancements, we require at least .NET Framework 3.5. Typically you will only see this on a base Windows Server 2008 (and R2) install. To enable these improvements, it is suggested to upgrade to any x64 version of Puppet (including 3.x), or to a Puppet version newer than 3.x and ensure you have at least .NET Framework 3.5 installed.

        Attachments

          Activity

            People

            Assignee:
            glenn.sarti Glenn Sarti
            Reporter:
            martin.ewings Marty Ewings
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support