Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-7042

puppetlabs-chocolatey : $chocolatey_version noop

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Chocolatey 3.2.0
    • Component/s: chocolatey
    • Labels:
    • Template:
      MODULES Bug Template
    • Acceptance Criteria:
      Hide

      This ticket will update and clarify the documentation as an initial triage step towards the confusion and ambiguity.

      Show
      This ticket will update and clarify the documentation as an initial triage step towards the confusion and ambiguity.
    • Team:
      Windows
    • Story Points:
      1
    • Sprint:
      Windows 2019-02-06
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 3.0.0
      Puppet Version: 5.5.1
      OS Name/Version: Windows 10 (1709)

      The $chocolatey_version param has no effect and bootstraps the most recent version of chocolatey. In my env, this causes errors later when chocolary tries to downgrade itself.

      Desired Behavior: Parameter is working as intended

      Actual Behavior:

      params.pp sets up a value which causes the most recent version do be downloaded by install.ps1. I could not find any reference to the version; but this parameter needs to be modified if a version is actually specified.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              erick Erick Banks
              Reporter:
              helge Daniel Helgenberger
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support