Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-7156

puppetlabs-dsc : Build docs are out of date

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: dsc
    • Labels:
      None
    • Template:
      MODULES Bug Template
    • Acceptance Criteria:
      Hide

      The docs for building custom resources should be complete-able and a custom dsc resource should be successfully created as a puppet type.

      Show
      The docs for building custom resources should be complete-able and a custom dsc resource should be successfully created as a puppet type.
    • Team:
      Windows
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      The build docs for puppetlabs/dsc are out of date:

      https://github.com/puppetlabs/puppetlabs-dsc/blob/master/README_CENTOS6.md

      https://github.com/puppetlabs/puppetlabs-dsc/blob/master/README_BUILD.md#building-puppet-types-from-custom-dsc-resources

      Can't complete.

      `bundle install` throws:

      Could not find gem 'puppet-module-posix-default-r1.9' in any of the gem sources listed in your Gemfile.

       

       

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            nickgw Nick GW
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support