Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-7324

"syncversion" maybe obsolete for selmodule type in Fedora >= 23

    Details

    • Type: Bug
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: selinux_core
    • Environment:

      Fedora F22 packages/Puppet 4.3.1 code running on Fedora 23

    • Template:
    • Team:
      Platform OS

      Description

      Under CentOS 7, semodule -l (which the selmodule provider uses to check the loaded module version) returns a version number, e.g. (from CentOS 7):

      root@srv-cfgmgt ~
       # semodule -l
      abrt	1.4.1	
      accountsd	1.1.0	
      acct	1.6.0	
      afs	1.9.0	
      aiccu	1.1.0	
      aide	1.7.1	
      ajaxterm	1.0.0	
      alsa	1.12.2	
      

      Under Fedora 23, the output looks like this (e.g. no version specified):

       # semodule -l | head -10
      abrt
      accountsd
      acct
      afs
      aiccu
      aide
      ajaxterm
      alsa
      amanda
      amtu
      

      This causes "syncversion" to always report true when set, and always result in an active resource.

      My policycoreutils level on F23 is policycoreutils-2.4-18.fc23.x86_64

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  mjackson Martin Jackson
                  QA Contact:
                  Eric Thompson
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                  Dates

                  • Created:
                    Updated: