Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-7487

mysql : Change root password on every puppetrun with mariadb

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: mysql
    • Labels:
    • Template:
      MODULES Bug Template
    • Team:
      Modules
    • Method Found:
      Needs Assessment
    • Zendesk Ticket IDs:
      32264
    • Zendesk Ticket Count:
      1
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: v5.4.0
      Puppet Version: 4.10.8
      OS Name/Version: Debian 9.5 (stretch)
      MariaDB Version: 10.3.8 from Upstream (https://downloads.mariadb.org/)

       

      Every puppetrun i get a notice which says the root password was changed. But actually the password works just fine.

       

      Desired Behavior:

      No change.

      Actual Behavior:

       

      Debug: Executing: '/usr/bin/mysql --defaults-extra-file=/root/.my.cnf -NBe SELECT MAX_USER_CONNECTIONS, MAX_CONNECTIONS, MAX_QUESTIONS, MAX_UPDATES, SSL_TYPE, SSL_CIPHER, X509_ISSUER, X509_SUBJECT, PASSWORD /*!50508 , PLUGIN */ FROM mysql.user WHERE CONCAT(user, '@', host) = 'root@localhost''
      Debug: Executing: '/usr/bin/mysql --defaults-extra-file=/root/.my.cnf --database=mysql -e SET PASSWORD FOR 'root'@'localhost' = '*45CB89FC0609821F7B84435C7A9CAF449DF401C4''
      Notice: /Stage[main]/Mysql::Server::Root_password/Mysql_user[root@localhost]/password_hash: changed password
      

       

      mysql -e "select user, host, substring(password,1,10) as pw, plugin, substring(authentication_string, 1, 10) as a_s from mysql.user;"
      +------------------+-------------+------------+-----------------------+------------+
      | user             | host        | pw         | plugin                | a_s        |
      +------------------+-------------+------------+-----------------------+------------+
      | root             | localhost   |            | mysql_native_password | *45CA59FC0 |
      | root             | 127.0.0.1   |            |                       |            |
      | root             | ::1         |            |                       |            |
      | debian-sys-maint | localhost   | *D511D60E6 |                       |            |
      | monitoring       | %           | *968D4B25F |                       |            |
      | repl             | %           | *F8D3C65A3 |                       |            |
      | crm              | 10.10.64.41 | *B29F4DB36 |                       |            |
      | crm              | 10.13.0.27  | *B29F4DB36 |                       |            |
      | mysqlbackup      | localhost   | *5ECBB7DB3 |                       |            |
      +------------------+-------------+------------+-----------------------+------------+
      
      

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              Luitzifa Daniel Krämer
              Votes:
              3 Vote for this issue
              Watchers:
              12 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support