Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-7548

puppetdb: Impossible Version Compability in 7.0.0/Puppet 5.x Support

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppetdb
    • Labels:
      None
    • Environment:

      Ubuntu 18.04, Puppet 5.x

    • Template:
      MODULES Bug Template
    • Acceptance Criteria:
      Hide

      Temporary Fix: Remove 18.04 from metadata.json.

      Long Term Fix: Test against Puppet 5.x and update Metadata.json to Puppet < 6.0.0.

      Show
      Temporary Fix: Remove 18.04 from metadata.json. Long Term Fix: Test against Puppet 5.x and update Metadata.json to Puppet < 6.0.0.
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      metadata.json for puppetdb module 7.0.0 expresses support for Ubuntu 18.04, but Puppet version < 5.0.0.  This is problematic because 18.04 ships with puppet 5.x and official puppet repos only exist for 18.04 (bionic) >= 5.x.  Also Puppet < 5.0.0 is probably not supported much longer?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              nabber00 Neil M
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support