Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-7668

puppetlabs-apt 5.x does not support Puppet 4.7

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: apt

      Description

      The metadata.json in the puppetlabs-apt module for 5.0.0 and 5.0.1 has "version_requirement": ">= 4.7.0 < 6.0.0". However, because Timestamp was introduced in https://github.com/puppetlabs/puppetlabs-apt/pull/743, only 4.8.0+ is compatible. PUP-5871 has the implementation details for Timestamp.

      The version_requirement should be "version_requirement": ">= 4.8.0 < 6.0.0" to reflect this change in 5.0.0+.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              jarret.lavallee Jarret Lavallee
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support