Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-7751

Module Dependencies for puppet_agent module need to be updated.

    Details

    • Template:
    • Team:
      Platform OS
    • QA Risk Assessment:
      Needs Assessment

      Description

      The dependencies for the puppet_agent module appear to be quite out of date, with the highest versions permissible for the puppetlabs-stdlib module being < 5.0.0, the puppetlabs-apt module being < 3.0.0 and the puppetlabs-inifile <= 2.1.0.

      puppetlabs-stdlib has had version 5.0.0 released, with very specific changes to the functions available, and in cases where the puppet_agent module is used to update to the latest puppet agent version, it should be able to use the latest stdlib too.

      puppetlabs-apt is up to version 5.0.1 and the mismatch in customer's versions and the dependency in the puppet_agent causes issues.

      Is there a reason for keeping the dependencies at this specific level, or would there be a downside to bumping the max version to allow the latest versions of these modules to be used?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                stefan.pijnappels Stefan Pijnappels
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support