Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-7762

puppetlabs-dsc : does not document specific minimum version of powershell required

    XMLWordPrintable

    Details

    • Template:
    • Acceptance Criteria:
      Hide

      Document the requirement as the RTM version or 5.0.10586.117

      Show
      Document the requirement as the RTM version or 5.0.10586.117
    • Team:
      Windows
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: '1.6.0'
      Puppet Version: N/A
      OS Name/Version: Windows

      The README documents "PowerShell 5, which is included in Windows Management Framework 5.0", but the module specifically requires 5.0.10586.117 or newer

      The CHANGELOG alludes to this: "Restricted WMF version to 5.0 RTM or above" but that requires users to know the RTM version number.

      _https://github.com/puppetlabs/puppetlabs-dsc/blob/master/build/dsc/templates/dsc_type.rb.erb#L265_

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              william.hurt William Hurt
              Reporter:
              tom.kishel Thomas Kishel
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support