Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-8080

puppet_agent : breaks (missing platform_tag) on puppetserver 5.3.5 (agent 5.6.5)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppet_agent
    • Labels:
      None
    • Template:
      MODULES Bug Template
    • Team:
      Night's Watch
    • Story Points:
      1
    • Sprint:
      PR - 2019-07-10
    • Method Found:
      Needs Assessment
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      When trying to upgrade to newest 1.7.0 of module I get this:

      Error: Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Evaluation Error: Unknown variable: '::platform_tag'. (file: /etc/puppetlabs/code/envs/b56v/modules/puppet_agent/manifests/install.pp, line: 191, column: 14)

      puppetserver is latest from puppet5 (puppetserver-5.3.5). The one we have now (1.3.2) works fine - except is is complaining about source_permissions being deprecated.

        Attachments

          Activity

            People

            Assignee:
            gabriel.nagy Gabriel Nagy
            Reporter:
            KlavsKlavsen Klavs Klavsen
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support