Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-8193

mysql module will break on 5.5.7 and 6.x

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: mysql
    • Labels:
      None
    • Template:
      MODULES Bug Template
    • Team:
      Modules
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      In Puppet 5.5.7, legacy functions that had ruby functions defined in the file no longer work. An example would be https://github.com/puppetlabs/puppetlabs-mysql/blob/5.4.0/lib/puppet/parser/functions/mysql_deepmerge.rb#L41-L58, but any Puppet function that defines ruby functions like this will break and should be fixed.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              david.swan David Swan
              Reporter:
              mwhahaha Alex Schultz
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support