Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-8263

puppet_agent : bump module dependency versions

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppet_agent
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      *Module Version:1.7.0
      *Puppet Version:2019.0.1
      *OS Name/Version:Centos/Redhat 7

      Bump module dependencies versions for puppet_agent module.

      Desired Behavior:
      Being able to use latest inifile/apt/stdlib modules from forge.
      The actual version of puppet_agent have requirement related to really old version of some modules.

      Actual Behavior:
      version 1.7.0 have those requirement:
      puppetlabs-stdlib (>= 4.6.0 < 5.0.0)
      puppetlabs-transition (>= 0.1.1 < 0.2.0)
      puppetlabs-inifile (>= 1.2.0 <= 2.1.0)
      puppetlabs-apt (>= 2.0.1 < 3.0.0)

      Some of those modules are not even supported with puppet 2019.0.1 (for example it require stdlib >5.0.0).

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  casey.williams Casey Williams
                  Reporter:
                  fduranti Francesco Duranti
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Zendesk Support