Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-8307

powershell : SPIKE figure out options for supporting powershell and powershell core

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Additional tickets that will track the work to support both versions of powershell in the puppetlabs-powershell module.

      Advertise to the community about our tbd approach and solicit feedback.

      Show
      Additional tickets that will track the work to support both versions of powershell in the puppetlabs-powershell module. Advertise to the community about our tbd approach and solicit feedback.
    • Team:
      Windows
    • Story Points:
      1
    • Sprint:
      Windows 2018-12-05, Windows 2018-12-12
    • QA Risk Assessment:
      Needs Assessment

      Description

      Powershell 6 has different installation options, different binary, and is cross-platform which differs from system installed Windows Powershell. This ticket will track the work to come up with options to support powershell 6 in the puppetlabs-powershell module.

      Note: this has implications for powershell management module.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              glenn.sarti Glenn Sarti
              Reporter:
              erick Erick Banks
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support