Details

    • Type: Epic
    • Status: Closed
    • Priority: Normal
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppet_agent
    • Labels:
      None
    • Epic Name:
      Modernize puppet_agent module
    • Template:
    • Team/s:
      Platform OS
    • QA Risk Assessment:
      Needs Assessment

      Description

      From the last time we talked about this:

      • We need to make sure the dependencies are on the latest versions
        • Or at least, latest that support Platform 4
      • We need to fix our test paths to stop testing Puppet 3.
        • We want to test 4->5 and 5->6 (at both unit and acceptance levels)
        • We should base our actual versions on supported PE upgrade paths (davis to irving, and irving to johnson/kerney/lovejoy/etc.)
      • We need to sort out mcollective upgrade stories (it's removed in Platform 6, and may not even be enabled in Platform 5)
      • We should remove any old platforms from the metadata, while we're at it.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                branan Branan Riley
              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support