Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-8348

Use beaker-puppet in puppetlabs-puppet_agent acceptance instead of beaker-puppet_install_helper

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppet_agent
    • Labels:
      None
    • QA Risk Assessment:
      Needs Assessment

      Description

      Before we release puppet_agent 2.0, we will need to fix integration tests and remove puppet 3 support. We also want to focus the repo's acceptance tests on testing FOSS installations, and leave PE-related tests to enterprise integration.

      The current tool used to provision SUTs in these tests, beaker-puppet_install_helper, is unsupported. MODULES-8315 describes a new acceptance testing framework that will replace beaker for modules testing, but that repo is not shared outside the modules team. Our available alternative is beaker-puppet, which is used in platform integration to install puppet-agent, but there is some missing functionality to implement in beaker-puppet before we can fully replace our provisioning methods and FOSS-ify our tests.

      For this ticket, puppet_agent's beaker tests should be upgraded to use beaker-puppet as a provisioning tool, removing any puppet-3-specific tests along the way as necessary. New beaker tickets should be created as necessary for supporting work in beaker-puppet.

       

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                casey.williams Casey Williams
                Reporter:
                casey.williams Casey Williams
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support