Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-8399

Remove puppetlabs-transition as a puppet_agent module dependency

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet_agent 2.0.0
    • Component/s: puppet_agent
    • Labels:
      None
    • Template:
    • Team:
      Platform OS
    • Sprint:
      Platform OS Kanban
    • QA Risk Assessment:
      Needs Assessment

      Description

      puppetlabs-transition hasn't been updated in around four years - it seems to still work adequately with puppet 6 upgrades in PE testing, but we'd like to remove it as a dependency for the 2.0 release of puppet_agent, since few codepaths use it anyway.

      remove_packages seems to be the place where this may matter the most. Where transition is used right now, we should use a script to do the upgrade/downgrade work instead (as with Solaris, for example).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              casey.williams Casey Williams
              Reporter:
              casey.williams Casey Williams
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support