Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-8518

apache : some warnings spread over two lines

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: apache
    • Labels:
      None
    • Template:
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: puppetlabs-apache
      Puppet Version: 5.5
      OS Name/Version: Debian 7-10, Ubuntu LTS 16-18

      Some warning this module issues, namely those inĀ templates/mod/_require.erb, span two lines instead of just one, for example:

        <%- scope.function_warning(["Class #{@title}: Using Allow"]) -%>
        <%- scope.function_warning(["is deprecated in Apache #{@_apache_version}"]) -%>
      

      This is logged as two lines which can be quite confusing when reading or grepping in the server log. Can that be changed to a single line?

        Attachments

          Activity

            People

            Assignee:
            rj667 Robert Scheer
            Reporter:
            rj667 Robert Scheer
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support