Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-8801

haproxy : haproxy module does not install or use rhsc rh-haproxy18

    Details

    • Type: Bug
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: haproxy
    • Labels:
    • Environment:

      Description

      Basic Info
      *Module Version:3.0.1
      *Puppet Version:5.5.10
      *OS Name/Version:Rhel 7

      Describe your issue in as much detail as possible...

      Desired Behavior:
      Install rh-haproxy18 from rhsc per the documentation.

      Actual Behavior:
      The module only ever installs the base version because all the parameters are still hard coded :
      package_name => 'haproxy'

      There is a parameter setup to get this data but the only time the parameter is ever used is in define haproxy::install and then it is overwritten as undef. I tried installing the package anally to see if the other parts would work, but it did not. Note that other than my extra customization the bit to install and use 18 is taken exactly from your documentation. If I am doing something incorrectly please let me know.

      Please take a moment and attach any relevant log output and/or manifests. This will help us immensely when troubleshooting the issue.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              thaylin Chris Bowen
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:

                Zendesk Support