Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-9058

sqlserver : Support for Sensitive

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: sqlserver, windows
    • Labels:
    • Template:
    • Team:
      Windows
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 2.5.0
      Puppet Version:
      OS Name/Version: Windows 2016

      Desired Behavior:

      **Password parameters accept sensitive.

      Actual Behavior:

      Warning: /Sqlserver_instance[instance]: Unable to mark 'sa_pwd' as sensitive: sa_pwd is a parameter and not a property, a
      nd cannot be automatically redacted.
      Warning: /Sqlserver_instance[instance]: Unable to mark 'agt_svc_password' as sensitive: agt_svc_password is a parameter a
      nd not a property, and cannot be automatically redacted.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            jessykah Jessykah Bird
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support