Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-9464

Puppet Agent Module TLS Version support

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Normal
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppet_agent
    • Labels:
      None
    • Template:
    • Team:
      Modules
    • CS Priority:
      Needs Priority
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Agent module is unable to update Puppet agent on Windows Server 2016 due to Windows 2016 disabling tlsv1 and Powershell runs tlsv1 by default. 

      Manual install of the agent works when specifying the tlsv12 as PowerShells default. But we are unable to specify the tls version when using the puppet agent module.

      Could we add a new parameter to the puppet agent module which allows you to specify the tls version that should be used when installing on windows agents?

       

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jason.stewart Jason Stewart
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support