Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-9492

puppetlabs_iis : resource iis_virtual_directory fails on second run

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: iis, windows
    • Labels:
    • Template:
      MODULES Bug Template
    • Acceptance Criteria:
      Hide

      Module should not show any error when virtual directory exists.

      Show
      Module should not show any error when virtual directory exists.
    • Team:
      Modules

      Description

      Basic Info
      Module Version: 4.5.1
      Puppet Version: 6.0.4
      OS Name/Version: Windows Server 2016 

       

      Desired Behavior:

      • On first run, iis_virtual_directory should create the VD as specified
      • On further runs, it should go on as VD exists

      Actual Behavior:

      • On first run, iis_virtual_directory creates the VD as specified
      • On further runs, it fails showing Powershell error in console and telling "-Force" flag should be used

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            lmayala Leonardo
            Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support