Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-9800

dsc_lite : Runs fail with invalid path for ENV['lib']

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: dsc_lite
    • Labels:
      None
    • Environment:

      Reproduced on Windows 2019 and Windows 2012 R2

      PE 2018.1.7

      Agent is 5.5.10

      dsc_lite version 2.0.1

    • Template:
      MODULES Bug Template
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      I am finding that Puppet runs fail with this error:

      Error: /Stage[main]/Profiles::Rds/Dsc[xRDSessionDeployment]: Could not evaluate: Bad configuration for ENV['lib']=C:\Program Files\Microsoft Visual Studio\DF98\IMSL\LIB;C:\Program Files\Microsoft Visual Studio\DF98\LIB;C:\Program Files\Microsoft Visual Studio\VC98\LIB - invalid path

      I'm getting this error even though all of the paths in 'lib' are valid.

      It is failing on a couple of different dsc_lite resources (all of the dsc_lite calls for that node).

      And I am able to reproduce the problem on a test server by creating the 'lib' environment variable. I tried having a path with no spaces in it and tried using a forward slash instead of backslash but I still get the error.

      The problem appears to have started when we upgraded dsc_lite to 2.0.1

      Nathan.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              william.hurt William Hurt
              Reporter:
              nde123 Nathan Epp
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support