Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1107

Evaluate shipping Ruby 2.4 in Puppet Agent

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 5.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      • a decision has been made about whether to move to Ruby 2.4 for Puppet 5, or stay on Ruby 2.3.3.
    • Team:
      Agent
    • Story Points:
      5
    • Sprint:
      Agent 2017-05-03, Agent 2017-05-31
    • Release Notes:
      Not Needed
    • Release Notes Summary:
      This is preliminary work to ensure puppet-agent runs on ruby 2.4. The actual switch to ruby 2.4 will be done in PA-1128.
    • QA Risk Assessment:
      No Action

      Description

      We need to determine the feasibility of moving to Ruby 2.4 in Puppet Agent for the PA 5 release. A pass of the release notes for Ruby 2.4 should be made, checking for any notable changes that might affect us. We also need to determine the difficulty of updating the Ruby component in the Agent, as well as vetting the implications of the bump in our tests and downstream (e.g. in PE and with puppetserver).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                qa qa
                Reporter:
                maggie Maggie Dreyer
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support