Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1128

Use Ruby 2.4.1

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 5.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      puppet-agent builds and uses Ruby 2.4.1

      Show
      puppet-agent builds and uses Ruby 2.4.1
    • Team:
      Agent
    • Story Points:
      1
    • Sprint:
      Agent 2017-05-31, Agent 2017-06-14
    • Release Notes:
      New Feature
    • Release Notes Summary:
      We are now shipping Ruby 2.4.1 in Puppet Agent. This is the Ruby that will be used by all programs also bundled in the Agent (e.g. Puppet, Facter).
    • QA Risk Assessment:
      No Action

      Description

      We added the configs for Ruby 2.4.1 in PA-1107, but did not actually switch to using it. When we are ready, we need to turn on Ruby 2.4.1 by updating these two lines: https://github.com/puppetlabs/puppet-agent/blob/master/configs/projects/puppet-agent.rb#L94-L95.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              maggie Maggie Dreyer
              QA Contact:
              Eric Delaney
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support