Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1162

Unable to load libruby.so.2.4.0 on AIX

    Details

    • Type: CI Blocker
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 5.0.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      • AIX 6.1
      • AIX 7.1
      • AIX 7.2
    • CI Pipeline/s:
      platform puppet-agent
    • Team:
      Agent
    • Story Points:
      2
    • Sprint:
      Agent 2017-06-14
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      No Action

      Description

      Using puppet-agent at SHA 5da7d74a9, facter is unable to load the vendored ruby library.

      example error:

        pe-aix-61-acceptance.delivery.puppetlabs.net (aix61-POWER-1) 01:34:09$ facter
          2017-05-31 18:34:09.842531 WARN  leatherman.ruby:484 - preferred ruby library "/opt/puppetlabs/puppet/lib/libruby.so.2.4.0" could not be loaded.
          2017-05-31 18:34:09.850628 WARN  puppetlabs.facter - could not locate a ruby library: facts requiring Ruby will not be resolved.
      

      joblink

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              john.duarte John Duarte
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support