Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-120

puppet agent installation requires new version of systemd and initscript -> new systemd crashes redhat 7.0

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Template:
    • Team:
      Platform OS

      Description

      Hi all.

      I'm working on a project where we have a huge infrastructure running on AWS and Puppet Enterprise 3.8 being used for the Configuration Management. Many components of my infrastructure have auto scaling group, it means I can have boxes created any time. New boxes created from auto scaling have puppet agent installed during the bootstrapping (using ec2 user data).

      Last week new boxes created from auto scaling group would crash after 1 hour from the creating time (the box would lose network connection). I could have the box up again doing a simple reboot.

      We did some debugging and we figured out that the boxes were being crashed by the puppet agent installation. The bash script that does the installation of puppet agent was forcing the update of systemd and initscript.

      To simulate this problem I created a clean ec2 server in AWS using the official Redhat 7.0 ami-83e08db9 (Sydney region). After that, I executed a simple "yum update systemd initscript". 1 hour later, the box crashed (lost network connection).

      I've created a ticket for RedHat reporting this bug and they replied saying I should update NetworkManager and SELinux policy before updating systemd.

      I guess the bash script responsible for the installation of puppet agent should check the version of NetworkManager and SELinux before updating systemd then.

      Puppet agent is being installed through the default bash script from puppet master:
      curl -k https://puppet.xxxx:8140/packages/current/install.bash >/tmp/puppet.sh
      chmod a+x /tmp/puppet.sh
      /tmp/puppet.sh

      Puppet packages installed on the clients:

      • pe-puppet-enterprise-release-3.8.0.3-1.pe.el7.noarch
      • pe-puppet-3.8.0.0-1.pe.el7.noarch

      Puppet packages installed on puppet master:

      • pe-puppet-license-cli-0.1.7.5-1.pe.el7.noarch
      • pe-puppet-enterprise-release-3.8.0.3-1.pe.el7.noarch
      • pe-puppet-dashboard-2.1.6.1.178-1.pe.el7.x86_64
      • pe-puppetdb-2.3.2.1-1.el7.noarch
      • pe-puppetdb-terminus-2.3.2.1-1.el7.noarch
      • pe-puppetserver-common-3.8.0.0-1.pe.el7.noarch
      • pe-puppet-3.8.0.0-1.pe.el7.noarch
      • pe-puppetserver-1.0.9-1.el7.noarch

      To fix this problem, I had to pre-baked puppet agent in my AMIs and make sure I had the latest version of systemd on it.

      You can check more information about this bug on: https://bugzilla.redhat.com/show_bug.cgi?id=1285974

      Below are the steps and logs I've done to simulate the problem:
      1. Create an ec2 server using official redhat 7.0 ami-83e08db9
      2. Check linux version and packages version
      3. Install puppet agent through puppet master bash script
      4. Check new packages version
      5. Get a coffee. Wait 1 hour. Box crashes

      [ec2-user@ip-10-0-134-174 ~]$ cat /etc/redhat-release
      Red Hat Enterprise Linux Server release 7.0 (Maipo)
      [ec2-user@ip-10-0-134-174 ~]$ uname -a
      Linux ip-10-0-134-174.xxxx.net 3.10.0-123.8.1.el7.x86_64 #1 SMP Mon Aug 11 13:37:49 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux
      [ec2-user@ip-10-0-134-174 ~]$ sudo su
      [root@ip-10-0-134-174 ec2-user]# rpm -qa | egrep 'systemd|initscript|selinux|network|iptables'
      libselinux-2.2.2-6.el7.x86_64
      selinux-policy-targeted-3.12.1-153.el7_0.11.noarch
      systemd-libs-208-11.el7_0.2.x86_64
      selinux-policy-3.12.1-153.el7_0.11.noarch
      systemd-208-11.el7_0.2.x86_64
      systemd-sysv-208-11.el7_0.2.x86_64
      dracut-network-033-161.el7.x86_64
      libselinux-utils-2.2.2-6.el7.x86_64
      glib-networking-2.36.2-3.el7.x86_64
      iptables-1.4.21-13.el7.x86_64
      libselinux-python-2.2.2-6.el7.x86_64
      initscripts-9.49.17-1.el7_0.1.x86_64
      [root@ip-10-0-134-174 ec2-user]#
      [root@ip-10-0-134-174 ec2-user]#
      [root@ip-10-0-134-174 ec2-user]# curl -k https://puppet.xxxx.net:8140/packages/current/install.bash >/tmp/puppet.sh
      % Total % Received % Xferd Average Speed Time Time Time Current
      Dload Upload Total Spent Left Speed
      100 11758 100 11758 0 0 30310 0 -::- -::- -::- 30304
      [root@ip-10-0-134-174 ec2-user]# chmod a+x /tmp/puppet.sh
      [root@ip-10-0-134-174 ec2-user]# /tmp/puppet.sh
      Loaded plugins: amazon-id, rhui-lb

      Error getting repository data for pe_repo, repository not found
      Loaded plugins: amazon-id, rhui-lb
      puppetlabs-pepackages | 2.5 kB 00:00:00
      rhui-REGION-client-config-server-7 | 2.9 kB 00:00:00
      rhui-REGION-rhel-server-releases | 4.0 kB 00:00:00
      rhui-REGION-rhel-server-rh-common | 3.8 kB 00:00:00
      (1/8): puppetlabs-pepackages/primary_db | 37 kB 00:00:00
      (2/8): rhui-REGION-client-config-server-7/x86_64/primary_db | 5.4 kB 00:00:00
      (3/8): rhui-REGION-rhel-server-releases/7Server/x86_64/group | 873 kB 00:00:00
      (4/8): rhui-REGION-rhel-server-rh-common/7Server/x86_64/group | 104 B 00:00:00
      (5/8): rhui-REGION-rhel-server-rh-common/7Server/x86_64/primary_db | 89 kB 00:00:00
      (6/8): rhui-REGION-rhel-server-rh-common/7Server/x86_64/updateinfo | 47 kB 00:00:00
      (7/8): rhui-REGION-rhel-server-releases/7Server/x86_64/updateinfo | 2.8 MB 00:00:01
      (8/8): rhui-REGION-rhel-server-releases/7Server/x86_64/primary_db | 20 MB 00:00:02
      Resolving Dependencies
      --> Running transaction check
      ---> Package pe-agent.noarch 0:3.8.0-1.pe.el7 will be installed
      --> Processing Dependency: pe-virt-what >= 1.14-1.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-rubygem-net-ssh >= 2.1.4-2.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-rubygem-deep-merge >= 1.0.0-4.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-ruby-stomp >= 1.3.3-1.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-ruby-shadow >= 2.2.0-3.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-ruby-selinux >= 2.0.94-4.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-ruby-rgen >= 0.6.5-1.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-ruby-ldap >= 0.9.12-7.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-ruby-augeas >= 0.5.0-7.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-ruby >= 1.9.3.551-2.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-puppet-enterprise-release >= 3.8.0.3-1.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-puppet >= 3.8.0.0-1.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-openssl >= 1.0.0r-1.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-mcollective-common >= 2.7.0.1-1.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-mcollective >= 2.7.0.1-1.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-libyaml >= 0.1.6-5.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-libldap >= 2.4.39-5.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-hiera >= 1.3.4.5-1.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-facter >= 2.4.3.2-1.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Processing Dependency: pe-augeas >= 1.3.0-1.pe.el7 for package: pe-agent-3.8.0-1.pe.el7.noarch
      --> Running transaction check
      ---> Package pe-augeas.x86_64 0:1.3.0-1.pe.el7 will be installed
      ---> Package pe-facter.x86_64 0:2.4.3.2-1.pe.el7 will be installed
      --> Processing Dependency: pciutils for package: pe-facter-2.4.3.2-1.pe.el7.x86_64
      ---> Package pe-hiera.noarch 0:1.3.4.5-1.pe.el7 will be installed
      ---> Package pe-libldap.x86_64 0:2.4.39-5.pe.el7 will be installed
      --> Processing Dependency: cyrus-sasl for package: pe-libldap-2.4.39-5.pe.el7.x86_64
      ---> Package pe-libyaml.x86_64 0:0.1.6-5.el7 will be installed
      ---> Package pe-mcollective.noarch 0:2.7.0.1-1.pe.el7 will be installed
      ---> Package pe-mcollective-common.noarch 0:2.7.0.1-1.pe.el7 will be installed
      ---> Package pe-openssl.x86_64 0:1.0.0r-1.pe.el7 will be installed
      ---> Package pe-puppet.noarch 0:3.8.0.0-1.pe.el7 will be installed
      ---> Package pe-puppet-enterprise-release.noarch 0:3.8.0.3-1.pe.el7 will be installed
      ---> Package pe-ruby.x86_64 0:1.9.3.551-2.pe.el7 will be installed
      ---> Package pe-ruby-augeas.x86_64 0:0.5.0-7.pe.el7 will be installed
      ---> Package pe-ruby-ldap.x86_64 0:0.9.12-7.pe.el7 will be installed
      ---> Package pe-ruby-rgen.noarch 0:0.6.5-1.pe.el7 will be installed
      ---> Package pe-ruby-selinux.x86_64 0:2.0.94-4.pe.el7 will be installed
      ---> Package pe-ruby-shadow.x86_64 0:2.2.0-3.pe.el7 will be installed
      ---> Package pe-ruby-stomp.noarch 0:1.3.3-1.pe.el7 will be installed
      ---> Package pe-rubygem-deep-merge.noarch 0:1.0.0-4.pe.el7 will be installed
      ---> Package pe-rubygem-net-ssh.noarch 0:2.1.4-2.pe.el7 will be installed
      ---> Package pe-virt-what.x86_64 0:1.14-1.el7 will be installed
      --> Running transaction check
      ---> Package cyrus-sasl.x86_64 0:2.1.26-19.2.el7 will be installed
      --> Processing Dependency: cyrus-sasl-lib(x86-64) = 2.1.26-19.2.el7 for package: cyrus-sasl-2.1.26-19.2.el7.x86_64
      --> Processing Dependency: systemd >= 219 for package: cyrus-sasl-2.1.26-19.2.el7.x86_64
      ---> Package pciutils.x86_64 0:3.2.1-4.el7 will be installed
      --> Running transaction check
      ---> Package cyrus-sasl-lib.x86_64 0:2.1.26-17.el7 will be updated
      ---> Package cyrus-sasl-lib.x86_64 0:2.1.26-19.2.el7 will be an update
      ---> Package systemd.x86_64 0:208-11.el7_0.2 will be updated
      --> Processing Dependency: systemd = 208-11.el7_0.2 for package: systemd-sysv-208-11.el7_0.2.x86_64
      --> Processing Dependency: systemd = 208-11.el7_0.2 for package: libgudev1-208-11.el7_0.2.x86_64
      ---> Package systemd.x86_64 0:219-19.el7 will be an update
      --> Processing Dependency: systemd-libs = 219-19.el7 for package: systemd-219-19.el7.x86_64
      --> Processing Dependency: kmod >= 18-4 for package: systemd-219-19.el7.x86_64
      --> Running transaction check
      ---> Package kmod.x86_64 0:14-9.el7 will be updated
      ---> Package kmod.x86_64 0:20-5.el7 will be an update
      ---> Package libgudev1.x86_64 0:208-11.el7_0.2 will be updated
      ---> Package libgudev1.x86_64 0:219-19.el7 will be an update
      ---> Package systemd-libs.x86_64 0:208-11.el7_0.2 will be updated
      ---> Package systemd-libs.x86_64 0:219-19.el7 will be an update
      ---> Package systemd-sysv.x86_64 0:208-11.el7_0.2 will be updated
      ---> Package systemd-sysv.x86_64 0:219-19.el7 will be an update
      --> Processing Conflict: systemd-219-19.el7.x86_64 conflicts dracut < 033-243
      --> Restarting Dependency Resolution with new changes.
      --> Running transaction check
      ---> Package dracut.x86_64 0:033-161.el7 will be updated
      --> Processing Dependency: dracut = 033-161.el7 for package: dracut-config-generic-033-161.el7.x86_64
      --> Processing Dependency: dracut = 033-161.el7 for package: dracut-network-033-161.el7.x86_64
      --> Processing Dependency: dracut = 033-161.el7 for package: dracut-config-rescue-033-161.el7.x86_64
      ---> Package dracut.x86_64 0:033-359.el7 will be an update
      --> Running transaction check
      ---> Package dracut-config-generic.x86_64 0:033-161.el7 will be updated
      ---> Package dracut-config-generic.x86_64 0:033-359.el7 will be an update
      ---> Package dracut-config-rescue.x86_64 0:033-161.el7 will be updated
      ---> Package dracut-config-rescue.x86_64 0:033-359.el7 will be an update
      ---> Package dracut-network.x86_64 0:033-161.el7 will be updated
      ---> Package dracut-network.x86_64 0:033-359.el7 will be an update
      --> Processing Conflict: systemd-219-19.el7.x86_64 conflicts initscripts < 9.49.28-1
      --> Restarting Dependency Resolution with new changes.
      --> Running transaction check
      ---> Package initscripts.x86_64 0:9.49.17-1.el7_0.1 will be updated
      ---> Package initscripts.x86_64 0:9.49.30-1.el7 will be an update
      --> Finished Dependency Resolution

      Dependencies Resolved

      ==================================================================================================================================
      Package Arch Version Repository Size
      ==================================================================================================================================
      Installing:
      pe-agent noarch 3.8.0-1.pe.el7 puppetlabs-pepackages 3.7 k
      Updating:
      dracut x86_64 033-359.el7 rhui-REGION-rhel-server-releases 311 k
      initscripts x86_64 9.49.30-1.el7 rhui-REGION-rhel-server-releases 429 k
      Installing for dependencies:
      cyrus-sasl x86_64 2.1.26-19.2.el7 rhui-REGION-rhel-server-releases 88 k
      pciutils x86_64 3.2.1-4.el7 rhui-REGION-rhel-server-releases 90 k
      pe-augeas x86_64 1.3.0-1.pe.el7 puppetlabs-pepackages 518 k
      pe-facter x86_64 2.4.3.2-1.pe.el7 puppetlabs-pepackages 98 k
      pe-hiera noarch 1.3.4.5-1.pe.el7 puppetlabs-pepackages 18 k
      pe-libldap x86_64 2.4.39-5.pe.el7 puppetlabs-pepackages 746 k
      pe-libyaml x86_64 0.1.6-5.el7 puppetlabs-pepackages 204 k
      pe-mcollective noarch 2.7.0.1-1.pe.el7 puppetlabs-pepackages 7.1 k
      pe-mcollective-common noarch 2.7.0.1-1.pe.el7 puppetlabs-pepackages 128 k
      pe-openssl x86_64 1.0.0r-1.pe.el7 puppetlabs-pepackages 7.6 M
      pe-puppet noarch 3.8.0.0-1.pe.el7 puppetlabs-pepackages 1.5 M
      pe-puppet-enterprise-release noarch 3.8.0.3-1.pe.el7 puppetlabs-pepackages 12 k
      pe-ruby x86_64 1.9.3.551-2.pe.el7 puppetlabs-pepackages 8.2 M
      pe-ruby-augeas x86_64 0.5.0-7.pe.el7 puppetlabs-pepackages 23 k
      pe-ruby-ldap x86_64 0.9.12-7.pe.el7 puppetlabs-pepackages 47 k
      pe-ruby-rgen noarch 0.6.5-1.pe.el7 puppetlabs-pepackages 218 k
      pe-ruby-selinux x86_64 2.0.94-4.pe.el7 puppetlabs-pepackages 60 k
      pe-ruby-shadow x86_64 2.2.0-3.pe.el7 puppetlabs-pepackages 12 k
      pe-ruby-stomp noarch 1.3.3-1.pe.el7 puppetlabs-pepackages 53 k
      pe-rubygem-deep-merge noarch 1.0.0-4.pe.el7 puppetlabs-pepackages 73 k
      pe-rubygem-net-ssh noarch 2.1.4-2.pe.el7 puppetlabs-pepackages 226 k
      pe-virt-what x86_64 1.14-1.el7 puppetlabs-pepackages 22 k
      Updating for dependencies:
      cyrus-sasl-lib x86_64 2.1.26-19.2.el7 rhui-REGION-rhel-server-releases 155 k
      dracut-config-generic x86_64 033-359.el7 rhui-REGION-rhel-server-releases 48 k
      dracut-config-rescue x86_64 033-359.el7 rhui-REGION-rhel-server-releases 49 k
      dracut-network x86_64 033-359.el7 rhui-REGION-rhel-server-releases 90 k
      kmod x86_64 20-5.el7 rhui-REGION-rhel-server-releases 114 k
      libgudev1 x86_64 219-19.el7 rhui-REGION-rhel-server-releases 64 k
      systemd x86_64 219-19.el7 rhui-REGION-rhel-server-releases 5.1 M
      systemd-libs x86_64 219-19.el7 rhui-REGION-rhel-server-releases 356 k
      systemd-sysv x86_64 219-19.el7 rhui-REGION-rhel-server-releases 52 k

      Transaction Summary
      ==================================================================================================================================
      Install 1 Package (+22 Dependent packages)
      Upgrade 2 Packages (+ 9 Dependent packages)

      Total download size: 27 M
      Downloading packages:
      Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
      (1/34): cyrus-sasl-2.1.26-19.2.el7.x86_64.rpm | 88 kB 00:00:00
      (2/34): cyrus-sasl-lib-2.1.26-19.2.el7.x86_64.rpm | 155 kB 00:00:00
      (3/34): dracut-033-359.el7.x86_64.rpm | 311 kB 00:00:00
      (4/34): dracut-config-generic-033-359.el7.x86_64.rpm | 48 kB 00:00:00
      (5/34): dracut-network-033-359.el7.x86_64.rpm | 90 kB 00:00:00
      (6/34): dracut-config-rescue-033-359.el7.x86_64.rpm | 49 kB 00:00:00
      (7/34): initscripts-9.49.30-1.el7.x86_64.rpm | 429 kB 00:00:00
      (8/34): libgudev1-219-19.el7.x86_64.rpm | 64 kB 00:00:00
      (9/34): kmod-20-5.el7.x86_64.rpm | 114 kB 00:00:00
      (10/34): pciutils-3.2.1-4.el7.x86_64.rpm | 90 kB 00:00:00
      warning: /var/cache/yum/x86_64/7Server/puppetlabs-pepackages/packages/pe-agent-3.8.0-1.pe.el7.noarch.rpm: Header V4 RSA/SHA1 Signature, key ID 4bd6ec30: NOKEY
      Public key for pe-agent-3.8.0-1.pe.el7.noarch.rpm is not installed
      (11/34): pe-agent-3.8.0-1.pe.el7.noarch.rpm | 3.7 kB 00:00:00
      (12/34): pe-facter-2.4.3.2-1.pe.el7.x86_64.rpm | 98 kB 00:00:00
      (13/34): pe-augeas-1.3.0-1.pe.el7.x86_64.rpm | 518 kB 00:00:00
      (14/34): pe-hiera-1.3.4.5-1.pe.el7.noarch.rpm | 18 kB 00:00:01
      (15/34): pe-libyaml-0.1.6-5.el7.x86_64.rpm | 204 kB 00:00:00
      (16/34): pe-mcollective-2.7.0.1-1.pe.el7.noarch.rpm | 7.1 kB 00:00:00
      (17/34): pe-mcollective-common-2.7.0.1-1.pe.el7.noarch.rpm | 128 kB 00:00:00
      (18/34): pe-libldap-2.4.39-5.pe.el7.x86_64.rpm | 746 kB 00:00:00
      (19/34): pe-puppet-3.8.0.0-1.pe.el7.noarch.rpm | 1.5 MB 00:00:00
      (20/34): pe-puppet-enterprise-release-3.8.0.3-1.pe.el7.noarch.rpm | 12 kB 00:00:00
      (21/34): pe-openssl-1.0.0r-1.pe.el7.x86_64.rpm | 7.6 MB 00:00:00
      (22/34): pe-ruby-augeas-0.5.0-7.pe.el7.x86_64.rpm | 23 kB 00:00:00
      (23/34): pe-ruby-ldap-0.9.12-7.pe.el7.x86_64.rpm | 47 kB 00:00:00
      (24/34): pe-ruby-rgen-0.6.5-1.pe.el7.noarch.rpm | 218 kB 00:00:00
      (25/34): pe-ruby-1.9.3.551-2.pe.el7.x86_64.rpm | 8.2 MB 00:00:00
      (26/34): pe-ruby-selinux-2.0.94-4.pe.el7.x86_64.rpm | 60 kB 00:00:00
      (27/34): pe-ruby-shadow-2.2.0-3.pe.el7.x86_64.rpm | 12 kB 00:00:00
      (28/34): pe-ruby-stomp-1.3.3-1.pe.el7.noarch.rpm | 53 kB 00:00:00
      (29/34): pe-rubygem-deep-merge-1.0.0-4.pe.el7.noarch.rpm | 73 kB 00:00:00
      (30/34): pe-rubygem-net-ssh-2.1.4-2.pe.el7.noarch.rpm | 226 kB 00:00:00
      (31/34): pe-virt-what-1.14-1.el7.x86_64.rpm | 22 kB 00:00:00
      (32/34): systemd-libs-219-19.el7.x86_64.rpm | 356 kB 00:00:00
      (33/34): systemd-sysv-219-19.el7.x86_64.rpm | 52 kB 00:00:00
      (34/34): systemd-219-19.el7.x86_64.rpm | 5.1 MB 00:00:00
      ----------------------------------------------------------------------------------------------------------------------------------
      Total 6.6 MB/s | 27 MB 00:00:04
      Retrieving key from https://puppet.xxxx.net:8140/packages/GPG-KEY-puppetlabs
      Importing GPG key 0x4BD6EC30:
      Userid : "Puppet Labs Release Key (Puppet Labs Release Key) <info@puppetlabs.com>"
      Fingerprint: 47b3 20eb 4c7c 375a a9da e1a0 1054 b7a2 4bd6 ec30
      From : https://puppet.xxxx.net:8140/packages/GPG-KEY-puppetlabs
      Running transaction check
      Running transaction test
      Transaction test succeeded
      Running transaction
      Installing : pe-puppet-enterprise-release-3.8.0.3-1.pe.el7.noarch 1/45
      Installing : pe-openssl-1.0.0r-1.pe.el7.x86_64 2/45
      Installing : pe-augeas-1.3.0-1.pe.el7.x86_64 3/45
      Installing : pe-virt-what-1.14-1.el7.x86_64 4/45
      Installing : pe-libyaml-0.1.6-5.el7.x86_64 5/45
      Installing : pe-ruby-1.9.3.551-2.pe.el7.x86_64 6/45
      Installing : pe-ruby-stomp-1.3.3-1.pe.el7.noarch 7/45
      Installing : pe-mcollective-common-2.7.0.1-1.pe.el7.noarch 8/45
      Installing : pe-ruby-rgen-0.6.5-1.pe.el7.noarch 9/45
      Installing : pe-ruby-selinux-2.0.94-4.pe.el7.x86_64 10/45
      Installing : pe-rubygem-deep-merge-1.0.0-4.pe.el7.noarch 11/45
      Installing : pe-hiera-1.3.4.5-1.pe.el7.noarch 12/45
      Installing : pe-ruby-augeas-0.5.0-7.pe.el7.x86_64 13/45
      Installing : pe-rubygem-net-ssh-2.1.4-2.pe.el7.noarch 14/45
      Updating : systemd-libs-219-19.el7.x86_64 15/45
      Updating : systemd-219-19.el7.x86_64 16/45
      warning: /etc/systemd/logind.conf created as /etc/systemd/logind.conf.rpmnew
      Updating : dracut-033-359.el7.x86_64 17/45
      Updating : kmod-20-5.el7.x86_64 18/45
      Updating : initscripts-9.49.30-1.el7.x86_64 19/45
      Installing : pe-mcollective-2.7.0.1-1.pe.el7.noarch 20/45
      Installing : pe-ruby-shadow-2.2.0-3.pe.el7.x86_64 21/45
      Updating : cyrus-sasl-lib-2.1.26-19.2.el7.x86_64 22/45
      Installing : cyrus-sasl-2.1.26-19.2.el7.x86_64 23/45
      Installing : pe-libldap-2.4.39-5.pe.el7.x86_64 24/45
      Installing : pe-ruby-ldap-0.9.12-7.pe.el7.x86_64 25/45
      Installing : pciutils-3.2.1-4.el7.x86_64 26/45
      Installing : pe-facter-2.4.3.2-1.pe.el7.x86_64 27/45
      Installing : pe-puppet-3.8.0.0-1.pe.el7.noarch 28/45
      Installing : pe-agent-3.8.0-1.pe.el7.noarch 29/45
      Updating : dracut-config-rescue-033-359.el7.x86_64 30/45
      Updating : dracut-network-033-359.el7.x86_64 31/45
      Updating : dracut-config-generic-033-359.el7.x86_64 32/45
      Updating : systemd-sysv-219-19.el7.x86_64 33/45
      Updating : libgudev1-219-19.el7.x86_64 34/45
      Cleanup : systemd-sysv-208-11.el7_0.2.x86_64 35/45
      Cleanup : dracut-config-generic-033-161.el7.x86_64 36/45
      Cleanup : dracut-network-033-161.el7.x86_64 37/45
      Cleanup : dracut-config-rescue-033-161.el7.x86_64 38/45
      Cleanup : dracut-033-161.el7.x86_64 39/45
      Cleanup : initscripts-9.49.17-1.el7_0.1.x86_64 40/45
      Cleanup : libgudev1-208-11.el7_0.2.x86_64 41/45
      Cleanup : systemd-208-11.el7_0.2.x86_64 42/45
      Cleanup : kmod-14-9.el7.x86_64 43/45
      Cleanup : systemd-libs-208-11.el7_0.2.x86_64 44/45
      Cleanup : cyrus-sasl-lib-2.1.26-17.el7.x86_64 45/45
      Verifying : dracut-config-rescue-033-359.el7.x86_64 1/45
      Verifying : pe-augeas-1.3.0-1.pe.el7.x86_64 2/45
      Verifying : pe-ruby-stomp-1.3.3-1.pe.el7.noarch 3/45
      Verifying : dracut-network-033-359.el7.x86_64 4/45
      Verifying : pe-ruby-rgen-0.6.5-1.pe.el7.noarch 5/45
      Verifying : pe-ruby-selinux-2.0.94-4.pe.el7.x86_64 6/45
      Verifying : dracut-config-generic-033-359.el7.x86_64 7/45
      Verifying : kmod-20-5.el7.x86_64 8/45
      Verifying : pe-ruby-shadow-2.2.0-3.pe.el7.x86_64 9/45
      Verifying : pe-openssl-1.0.0r-1.pe.el7.x86_64 10/45
      Verifying : pciutils-3.2.1-4.el7.x86_64 11/45
      Verifying : pe-puppet-3.8.0.0-1.pe.el7.noarch 12/45
      Verifying : pe-virt-what-1.14-1.el7.x86_64 13/45
      Verifying : systemd-sysv-219-19.el7.x86_64 14/45
      Verifying : pe-ruby-1.9.3.551-2.pe.el7.x86_64 15/45
      Verifying : pe-libyaml-0.1.6-5.el7.x86_64 16/45
      Verifying : libgudev1-219-19.el7.x86_64 17/45
      Verifying : cyrus-sasl-lib-2.1.26-19.2.el7.x86_64 18/45
      Verifying : systemd-219-19.el7.x86_64 19/45
      Verifying : pe-rubygem-deep-merge-1.0.0-4.pe.el7.noarch 20/45
      Verifying : dracut-033-359.el7.x86_64 21/45
      Verifying : systemd-libs-219-19.el7.x86_64 22/45
      Verifying : pe-mcollective-common-2.7.0.1-1.pe.el7.noarch 23/45
      Verifying : pe-facter-2.4.3.2-1.pe.el7.x86_64 24/45
      Verifying : pe-ruby-augeas-0.5.0-7.pe.el7.x86_64 25/45
      Verifying : pe-hiera-1.3.4.5-1.pe.el7.noarch 26/45
      Verifying : pe-agent-3.8.0-1.pe.el7.noarch 27/45
      Verifying : initscripts-9.49.30-1.el7.x86_64 28/45
      Verifying : pe-libldap-2.4.39-5.pe.el7.x86_64 29/45
      Verifying : pe-puppet-enterprise-release-3.8.0.3-1.pe.el7.noarch 30/45
      Verifying : pe-ruby-ldap-0.9.12-7.pe.el7.x86_64 31/45
      Verifying : cyrus-sasl-2.1.26-19.2.el7.x86_64 32/45
      Verifying : pe-rubygem-net-ssh-2.1.4-2.pe.el7.noarch 33/45
      Verifying : pe-mcollective-2.7.0.1-1.pe.el7.noarch 34/45
      Verifying : dracut-config-rescue-033-161.el7.x86_64 35/45
      Verifying : systemd-208-11.el7_0.2.x86_64 36/45
      Verifying : kmod-14-9.el7.x86_64 37/45
      Verifying : initscripts-9.49.17-1.el7_0.1.x86_64 38/45
      Verifying : dracut-033-161.el7.x86_64 39/45
      Verifying : cyrus-sasl-lib-2.1.26-17.el7.x86_64 40/45
      Verifying : libgudev1-208-11.el7_0.2.x86_64 41/45
      Verifying : systemd-libs-208-11.el7_0.2.x86_64 42/45
      Verifying : dracut-network-033-161.el7.x86_64 43/45
      Verifying : systemd-sysv-208-11.el7_0.2.x86_64 44/45
      Verifying : dracut-config-generic-033-161.el7.x86_64 45/45

      Installed:
      pe-agent.noarch 0:3.8.0-1.pe.el7

      Dependency Installed:
      cyrus-sasl.x86_64 0:2.1.26-19.2.el7 pciutils.x86_64 0:3.2.1-4.el7 pe-augeas.x86_64 0:1.3.0-1.pe.el7 pe-facter.x86_64 0:2.4.3.2-1.pe.el7
      pe-hiera.noarch 0:1.3.4.5-1.pe.el7 pe-libldap.x86_64 0:2.4.39-5.pe.el7 pe-libyaml.x86_64 0:0.1.6-5.el7 pe-mcollective.noarch 0:2.7.0.1-1.pe.el7
      pe-mcollective-common.noarch 0:2.7.0.1-1.pe.el7 pe-openssl.x86_64 0:1.0.0r-1.pe.el7 pe-puppet.noarch 0:3.8.0.0-1.pe.el7 pe-puppet-enterprise-release.noarch 0:3.8.0.3-1.pe.el7
      pe-ruby.x86_64 0:1.9.3.551-2.pe.el7 pe-ruby-augeas.x86_64 0:0.5.0-7.pe.el7 pe-ruby-ldap.x86_64 0:0.9.12-7.pe.el7 pe-ruby-rgen.noarch 0:0.6.5-1.pe.el7
      pe-ruby-selinux.x86_64 0:2.0.94-4.pe.el7 pe-ruby-shadow.x86_64 0:2.2.0-3.pe.el7 pe-ruby-stomp.noarch 0:1.3.3-1.pe.el7 pe-rubygem-deep-merge.noarch 0:1.0.0-4.pe.el7
      pe-rubygem-net-ssh.noarch 0:2.1.4-2.pe.el7 pe-virt-what.x86_64 0:1.14-1.el7

      Updated:
      dracut.x86_64 0:033-359.el7 initscripts.x86_64 0:9.49.30-1.el7

      Dependency Updated:
      cyrus-sasl-lib.x86_64 0:2.1.26-19.2.el7 dracut-config-generic.x86_64 0:033-359.el7 dracut-config-rescue.x86_64 0:033-359.el7 dracut-network.x86_64 0:033-359.el7 kmod.x86_64 0:20-5.el7 libgudev1.x86_64 0:219-19.el7
      systemd.x86_64 0:219-19.el7 systemd-libs.x86_64 0:219-19.el7 systemd-sysv.x86_64 0:219-19.el7

      Complete!
      Notice: /Service[pe-puppet]/ensure: ensure changed 'stopped' to 'running'
      service

      { 'pe-puppet': ensure => 'running', enable => 'true', }

      Notice: /File[/usr/local/bin/facter]/ensure: created
      file

      { '/usr/local/bin/facter': ensure => 'link', selrange => 's0', selrole => 'object_r', seltype => 'bin_t', seluser => 'system_u', target => '/opt/puppet/bin/facter', }

      Notice: /File[/usr/local/bin/puppet]/ensure: created
      file

      { '/usr/local/bin/puppet': ensure => 'link', selrange => 's0', selrole => 'object_r', seltype => 'bin_t', seluser => 'system_u', target => '/opt/puppet/bin/puppet', }

      Notice: /File[/usr/local/bin/pe-man]/ensure: created
      file

      { '/usr/local/bin/pe-man': ensure => 'link', selrange => 's0', selrole => 'object_r', seltype => 'bin_t', seluser => 'system_u', target => '/opt/puppet/bin/pe-man', }

      Notice: /File[/usr/local/bin/hiera]/ensure: created
      file

      { '/usr/local/bin/hiera': ensure => 'link', selrange => 's0', selrole => 'object_r', seltype => 'bin_t', seluser => 'system_u', target => '/opt/puppet/bin/hiera', }

      [root@ip-10-0-134-174 ec2-user]#
      [root@ip-10-0-134-174 ec2-user]# rpm -qa | egrep 'systemd|initscript|selinux|network|iptables'
      libselinux-2.2.2-6.el7.x86_64
      selinux-policy-targeted-3.12.1-153.el7_0.11.noarch
      pe-ruby-selinux-2.0.94-4.pe.el7.x86_64
      systemd-219-19.el7.x86_64
      selinux-policy-3.12.1-153.el7_0.11.noarch
      systemd-libs-219-19.el7.x86_64
      initscripts-9.49.30-1.el7.x86_64
      dracut-network-033-359.el7.x86_64
      systemd-sysv-219-19.el7.x86_64
      libselinux-utils-2.2.2-6.el7.x86_64
      glib-networking-2.36.2-3.el7.x86_64
      iptables-1.4.21-13.el7.x86_64
      libselinux-python-2.2.2-6.el7.x86_64
      [root@ip-10-0-134-174 ec2-user]#

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                ricardoxmit Ricardo Schmidt
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 2 days
                  2d
                  Remaining:
                  Remaining Estimate - 2 days
                  2d
                  Logged:
                  Time Spent - Not Specified
                  Not Specified