Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1262

Inconsistency in package metadata

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Normal
    • Resolution: Duplicate
    • None
    • None
    • None
    • None
    • Needs Assessment
    • Needs Assessment

    Description

      This is with the puppet5-releases repository installed on Ubuntu 16.04.

      apt-cache show puppet-agent
      Package: puppet-agent
      Version: 5.0.0-1xenial
       
      apt-cache show puppetdb
      Package: puppetdb
      Version: 5.0.1-1puppetlabs1
      

      The Version scheme is different. eg. x.y.z-1puppetlabs1 vs x.y.z-1xenial

      This may be fine, but would be interested to understand if the difference in scheme has a rationale? And if as part of the Platform work this might be worth reconciling.

      Note as well both of these packages show old puppetlabs details as well.

      $ apt-cache show puppet-agent | grep puppetlabs.com
      Maintainer: Puppet Labs <info@puppetlabs.com>
      Homepage: https://www.puppetlabs.com
      $ apt-cache show puppetdb | grep puppetlabs.com
      Maintainer: Puppet Labs <info@puppetlabs.com>
      Homepage: http://puppetlabs.com
      

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              gareth Gareth Rushgrove
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support