Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1465

Update to rubygems 2.6.13

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • puppet-agent 1.10.9
    • None
    • Hide

      Puppet-agent's vendored rubygems contains upstream fix for Rubygems CVE.

      Show
      Puppet-agent's vendored rubygems contains upstream fix for Rubygems CVE.
    • Platform OS
    • 3
    • Platform OS 2017-09-19, Platform OS 2017-10-03, Platform OS 2017-10-17, Platform OS 2017-10-31
    • Security Fix
    • Hide
      Created patches for CVE 2017 0902, 0899, 0900, and 0901 for Ruby 2.1.9. For Ruby 2.3.x and Ruby 2.4.x, the gem vulnerabilities described here were fixed when updating them to their latest versions in PA-1547.
      Show
      Created patches for CVE 2017 0902, 0899, 0900, and 0901 for Ruby 2.1.9. For Ruby 2.3.x and Ruby 2.4.x, the gem vulnerabilities described here were fixed when updating them to their latest versions in PA-1547 .
    • No Action

    Attachments

      Issue Links

        Activity

          People

            enis.inan Enis Inan
            morgan Morgan Rhodes
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support