Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1569

The puppet-agent MSI package is shipping win32-process 0.7.4, but the puppet gem depends on 0.7.5

    Details

    • Template:
    • Team:
      Windows
    • Story Points:
      1
    • Sprint:
      Windows Kanban
    • Method Found:
      Needs Assessment
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      No Action

      Description

      When PUP-6445 was merged as part of https://github.com/puppetlabs/puppet/commit/d4d6734e5f858b4e3f4db24c356ea7cb9db2d991, the win32-process gem was pinned as a gem dependency / source install workflow dependency. The corresponding dependency in the shipped puppet-agent packages was not updated as well, which was an oversight.

      This was discovered while working on BOLT-87, where a gem needs to be installed inside the vendored Ruby environment that's shipped with the puppet-agent MSI. During the install, win32-process should

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ethan Ethan Brown
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support