Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1628

Use latest tagged version of modules when validating puppet-agent builds

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Ready for Engineering
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Template:
    • Team:
      Platform OS
    • Story Points:
      1
    • QA Risk Assessment:
      Needs Assessment

      Description

      When validating puppet-agent builds, the build is tested against several modules. Currently, these tests occur against the latest commit on these modules. This results in two unknowns being tested against each other. The versions of the modules being tested against should be known good versions. Therefore puppet-agent should be validated against the latest tagged release versions of these modules.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            john.duarte John Duarte
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support