Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1734

Update the AIX p-a validate_vendored_ruby acceptance tests to use pl-gcc for the specific AIX version being tested

    Details

    • Type: Improvement
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Template:
    • Team:
      Platform OS
    • QA Risk Assessment:
      Needs Assessment

      Description

      Currently our validate_vendored_ruby acceptance tests for puppet-agent install the same pl-gcc package for both AIX 6.1 and 7.1 tests. Since the system headers within pl-gcc need to match that of the target OS, we've just been lucky that this hasn't caused issues with the ruby gems we've been using to test builds with.

      The test should be updated to install the pl-gcc package specific to the version of AIX being tested.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                scott.garman Scott Garman
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: