Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1881

Update semantic_puppet component in puppet-runtime

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 6.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide
      • Puppet-agent packages should include the most recent version of semantic_puppet 1.0.x from https://rubygems.org/gems/semantic_puppet.
      • Running /opt/puppetlabs/puppet/bin/gem list should list the most recent version.
      Show
      Puppet-agent packages should include the most recent version of semantic_puppet 1.0.x from https://rubygems.org/gems/semantic_puppet . Running /opt/puppetlabs/puppet/bin/gem list should list the most recent version.
    • Team:
      Platform Core
    • Sub-team:
    • Sprint:
      Platform Core KANBAN
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Update the vendored semantic_puppet gem in the puppet-agent package to the most recent version 1.0.2
    • QA Risk Assessment:
      No Action

      Description

      The puppet-runtime repo (https://github.com/puppetlabs/puppet-runtime) should depend on a more recent version of the semantic puppet gem. Note the puppet-agent package includes the prebuilt puppet-runtime artifacts since we don't want to rebuild ruby, openssl, etc during every puppet-agent build.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jorie Jorie Tappa
                Reporter:
                josh Josh Cooper
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support