Details

    • Type: Epic
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 6.0.0
    • Component/s: puppet-runtime
    • Labels:
      None
    • Epic Name:
      Ruby 2.5
    • Template:
    • Team/s:
      Platform OS
    • Epic Status:
      Done
    • QA Risk Assessment:
      Needs Assessment

      Description

      We will be upgrading ruby 2.4.4 to 2.5 in platform 6. These changes will take place in puppet-runtime so that they can be reused across puppet-agent, pdk, and bolt. 

      • OpenSSL must be updated to version 1.1.0 in puppet-runtime before this work can proceed
      • Ruby 2.4.4 should continue to be available in puppet-runtime

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  josh Josh Cooper
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Due:
                    Created:
                    Updated:
                    Resolved: