Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1925

Please include hiera-eyaml gem in agent, matching server version

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 5.5.1
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Platform OS
    • Sprint:
      Platform OS Kanban
    • Release Notes:
      New Feature
    • Release Notes Summary:
      puppet-agent 5.5.1 and above now ships the hiera-eyaml 2.1.0, highline 1.6.21 and trollop 2.1.2 gems in the shared gem directory.
    • QA Risk Assessment:
      Needs Assessment

      Description

      We incorporated hiera-eyaml into the puppetserver starting in version 5.2.0 (See SERVER-2066) but you can't use that version with the commandline tool and editor integration, so there's still a step required to install it into agent's gem area.

      It'd simplify the getting started workflow and provide a much more consistent user experience if we include the gem in the agent package as well, at a version that matches the one included in the server.

      (I think it's fine to only install it on master OSes, as it's not useful on agents)

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              enis.inan Enis Inan
              Reporter:
              eric.sorenson Eric Sorenson
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support