Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-1973

Create an Agent Upgrade pipeline

    Details

    • Type: Task
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Template:
    • Acceptance Criteria:
      • Each maintenance branch of puppet-agent is tested to confirm that older supported packages can upgrade to it.
    • Team:
      Platform OS
    • QA Risk Assessment:
      Needs Assessment

      Description

      At present, we do not test agent package upgrades in our suite. This testing is deferred until the PE integration tests, as part of their validation of the puppet_agent module.

      These tests should be migrated to the puppet-agent test suite, and focus as much as possible on testing that our packages can be upgraded correctly.

      This test suite should not use a master (as it would be unnecessary overhead), and ideally could be used as a way to get secondary coverage of the puppet_agent module.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              branan Branan Riley
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:

                Zendesk Support