Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-225

Remove pluginsync setting during agent upgrades

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 1.4.0
    • Component/s: Packaging
    • Labels:
      None

      Description

      The pluginsync setting is deprecated (PUP-5708) in puppet 4.4.0. New MSI installs will no longer set the pluginsync setting, see PA-231 (previously PUP-5769), however upgrades will preserve the setting.

      We either need to modify the MSI to remove the setting on upgrade, or modify the puppet_agent module to remove it. /cc Ethan Brown, Rob Reynolds, Michael Smith, William Hopper, Joshua Partlow

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                josh Josh Cooper
                QA Contact:
                Ryan Gard
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support